Деление и остаток

Дано трехзначное число x вводимое с клавиатуры. Напишите программу вычисляющую корень квадратный из суммы цифр числа.
Алгоритмический язык
Решение

алг
нач
  цел x,a,b,c
  ввод x
  a:=div(x,100)
  b:=mod(div(x,10),10)
  c:=mod(x,10)
  вывод 'rez= ',sqrt(a+b+c)
кон

Результат

123
rez= 2.44949

Pascal
Решение

var
x:integer;
begin
read(x);
writeln('rez= ',sqrt((x div 100)+((x div 10) mod 10)+(x mod 10)));
end.

Результат

123
rez= 2.44948974278318

Python 3
Решение

x = int(input('введите X '))
print('rez= ',((x//100)+((x//10)%10)+(x%10))**(1/2))

Результат

введите X 123
rez=  2.449489742783178

Python 3 (способ 2)
Решение

x = str(input('введите X ')); s = 0
for i in x:
    s+=int(i)
print('rez= ',s**(1/2))

Результат

введите X 123
rez=  2.449489742783178

C++
Решение

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
   int x,a,b,c;
   cin >> x;
   a = x/100;
   b = (x/10)%10;
   c = x%10;
   cout << "rez= "<< sqrt(a+b+c);
    return 0;
}

Результат

123
rez= 2.44949

2 комментария

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *