Циклы

Даны два числа, a и b (a<b). Вывести все четные числа, делящиеся на 3 в промежутке от a до b.
Алгоритмический язык.
Решение

алг
нач
  цел a,b,i
  ввод a
  ввод b
  нц для i от a до b
    если mod(i,2)=0 и mod(i,3)=0 то вывод i,' 'все
  кц
кон

Результат

3
20
6 12 18

Pascal
Решение

var
a,b,i:integer;
begin
read(a,b);
for i:=a to b do
if (i mod 2 = 0) and (i mod 3 = 0)then write(i,' ')
end.

Результат

3 20
6 12 18

Python3
Решение

a=int(input())
b=int(input())
for i in range(a,b+1):
    if i%2==0 and i%3==0:
        print(i,end='')

Результат

3
20
6 12 18

C++
Решение

#include <iostream>
using namespace std;
int main()
{
    int a,b;
    cin >> a >> b;
    for (int i=a; i<=b; i++){
        if (i%2==0 && i%3==0){
            cout << i <<' ';
        }
    }
    return 0;
}

Результат

3 20
6 12 18

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *